Mama’s Got A Brand New Bag…Uh…Toy!

I’m so excited about my new acquisition.  It was delivered and set up yesterday.

Queen Quilter
It’s a Queen Quilter by Tin Lizzie!
Queen 2
I am greatly disappointed as well. This is a used machine (with a one year warranty), and Tin Lizzie tested it thoroughly before they brought it out…a 400 mile drive…and everything was working fine. Unfortunately by the time it got here, the stitch regulator cable was no longer working and the man who brought it out had spare cables…just not one for this model. So the only type of quilting I can do until they send a replacement is straight stitching like for stitch-in-a-ditch. Fortunately, when the new cable arrives, my sweet hubby can just plug it in, and I should be ready to roll. The man also made a mistake with the frame. He forgot to measure the rails, and brought 8 foot rails instead of the promised 10 footers, and the pantograph set up that came with it will only work with the longer rails. Of course I can’t really use the pantographs until the stitch regulator is fixed. The trouble with asking God to give you patience is He gives you plenty of opportunity to practice it. 🙂
In the meantime, I’ve been madly working on quilts so that I would have something ready to quilt…once I master the machine. I have one completely ready and another that just needs borders & a back made.
I hope my new cable shows up tomorrow and I will actually be able to get something done over the weekend.

Advertisements

2 thoughts on “Mama’s Got A Brand New Bag…Uh…Toy!

  1. stitchinggrandma May 1, 2014 / 5:01 pm

    Wow; it has arrived. Understand your frustrations with the set up! Hope they are sending your 10 foot rail system soon!! Won’t it be fun. Think that practice will make perfect, take it slow and steady; and have fun with your swirls and feathers and flurishes. Practice on those charity quilts from the HALL and the Guild! I love the thread I got from Superior. My understanding is every machine has a “different” thread appetite!!

    • oneblockwonderwoman May 3, 2014 / 11:29 am

      Thanks for popping by and admiring my new baby. We received the parts yesterday and installed them this morning. It seems to be working…if I could just get the tension adjusted properly. I hate tension difficulties. Arrrggg!!!!
      We have to buy the rails ourselves because the frames don’t usually come with the rails, and they just brought the 8 footers that they just had laying around thinking they were ten footers. But they did bring me a set of leaders to go on the ten foot rails, which are usually an extra purchase as well. The leaders attach with velcro, and that is already installed on the leaders and the package also includes the velcro for the new rails. In the meantime, I just can’t quilt any king sized quilts.
      The man who came out recommended 60/40 poly/cotton thread, which will be a change for me since I normally use just cotton. He also said that serger thread tends to shred on the machine. So after I practice a little more, and get the pesky tension problem fixed, I’ll do some thread research on line. Thanks for the suggestion.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s